首页 » php程序 ▪ 插件

thinkphp6 composer 安装报错  Your requirements could not be resolved to an installable set of packages.

   发表于:php程序 ▪ 插件评论 ()   热度:88

thinkphp6 composer 安装报错  "Your requirements could not be resolved to an installable set of packages."

刚开始用  命令  composer create-project topthink/think ./blog2   安装结果报错

从网上找了半天 终于解决了 , 要加参数 "--ignore-platform-reqs"   命令如下 :

composer create-project --ignore-platform-reqs topthink/think tp8

composer require   --ignore-platform-reqs   topthink/think-multi-app

ok解决 , 但是至于为啥要加   --ignore-platform-reqs  这个参数 后边还得看看

 

 

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - topthink/framework v6.0.3 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
    - topthink/framework v6.0.2 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
    - topthink/framework v6.0.1 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
    - topthink/framework v6.0.0 requires ext-mbstring * -> the requested PHP extension mbstring is missing from your system.
    - Installation request for topthink/framework ^6.0.0 -> satisfiable by topthink/framework[v6.0.0, v6.0.1, v6.0.2, v6.0.3].

  To enable extensions, verify that they are enabled in your .ini files:
    - C:\php\php-7.2.33-1-nts\php.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

 

(。・v・。)
喜欢这篇文章吗?欢迎分享到你的微博、QQ群,并关注我们的微博,谢谢支持。