首页 » web服务器

Python2.7升级到Python3.5

   发表于:web服务器评论 ()   热度:313

1.查看Python版本: python -V

2.下载Python 3.5版本:wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz

3.解压:tar -zxvf Python-3.5.2.tgz

4.配置:./configure

5.编译(编译时间较长):make

6.安装:make install

7.关联:

先备份原来Python 2.7

再关联新Python 3.5

8.查看版本:python -V

升级python3,使用yum提示以下故障

File "/usr/bin/yum", line 30
    except KeyboardInterrupt, e:
                            ^
SyntaxError: invalid syntax

这是因为yum采用python作为命令解释器,这可以从/usr/bin/yum文件中第一行#!/usr/bin/python发现。而python版本之间兼容性不太好,使得2.X版本与3.0版本之间存在语法不一致问题。当系统将python升级到2.7或3.6后,出现语法解释错误。

解决办法:

修改yum的解释器为旧版本python2.7(如果你没有采用覆盖升级的话)。

修改yum的解释器为旧版本python2.7:

$ vi /usr/bin/yum

将第一行"#!/usr/bin/python" 改为 "#!/usr/bin/python2.7"即可。

如未解决,

$ vi /usr/libexec/urlgrabber-ext-down

将第一行"#!/usr/bin/python" 改为 "#!/usr/bin/python2.7"即可。

注:以上红字路径未原来python版本文件
 

安装软件时又会出现另一种报错

Downloading packages:
  File "/usr/libexec/urlgrabber-ext-down", line 28
    except OSError, e:
                  ^
SyntaxError: invalid syntax

问题与前面一个一样,因此解决办法也是一样的:

vi /usr/libexec/urlgrabber-ext-down

将第一行"#!/usr/bin/python" 改为 "#!/usr/bin/python2"即可。

(。・v・。)
喜欢这篇文章吗?欢迎分享到你的微博、QQ群,并关注我们的微博,谢谢支持。